fluval canister blows burst mirco bubbles

35% Off ! All WYSIWYG fish and corals
#1
my 305 fluval canister keeps blowing bursts of micro bubbles out every minute or two. what causes this? its driving me crazy
novice - please any suggestions
 
#2
Originally Posted by TODJ2002
my 305 fluval canister keeps blowing bursts of micro bubbles out every minute or two. what causes this? its driving me crazy
novice - please any suggestions


my 204 does the same thing! its annoying, usually only happenns after i clean it and change the filters though
 
#4
You probly have an air bubble. It may be trapped and you could work it out, or you may have a very small hairline crack in the top so it can't form an airtight seal.
I've had a Rena XP3 for a couple of years and never had any type of issue. So when they came out with the XP4 a few months ago I snatched it up. I spent litterally all day fighting with it. Tilting it, shakeing it, bumping it. Get the bubbles out, and 5 minutes later, here they are again. After fighting with it from 9:30 in the morning until after 11 that night, I gave up and put my old XP3 back on. No problem. The next day I took the XP4 back to the store where I got it from and told them what was going on. They checked it out and found a very small hairline crack where the intake hose attaches to the canister and the black rubber seal had a knick in it. They told my that is what the problem was and asked if I wanted to exchange it. Heck no, they don't have a clue how much work it is to take out a filter and hook out another system, just to take it off a few hours later. I wasn't going to spend a second day fighting with a filter.
I'm not saying one is better than the other, I don't know, I've never used a fluval. I am saying, check the area around the intake and return hoses, check your rubber seal. Something must be off and lettting air into your system. These filters should not burp and blow bubbles.
 

watson3

Active Member
#5
Mine does the exact same after cleaning/replacing media..Worst comes to worse, pump the hell out of it before you plug it back in..
 
#6
On my 90 gal, I have 2 Fluval 405 (opposite to ecah other). One is sporadically blowing bubbles in short bursts???
Maybe an miniscule intake to air somewhere???
Cannot figure it out yet
 
#8
The solution to this that I found is make sure that you empty all the water out of the Canister. Next remove the return head out of the water and them prime the unit. Allow it to completely fill before putting the return head back in the water and plug it back in. That should fix your problem.
 
#9
I had a rena xp3 and same problem,tried everything to no avail.
I returned it and got the fluval fx5,a bit big but some really cool features including a self purging function and no bubbles!
 
#10
I had the same problem and I found that my gasket was cracked, so what I did is I put a lil bit of Vaseline on the cracked parts.... this will complete the seal and eliminate the bubbles, unless u got the cash to buy a new seal the just go that rout.... lol
 
#11
It could be a tiny leak as suggested above, but it could also be cavitation. This happens when intake cannot keep up with the speed of the impeller and vacuum bubbles are formed on the back of the blades.

Thi is easy to test for. Restrict the output a little to see if the bubbles stop. Restricting the output slightly allows the input to keep up with what the impeller is pushing out.
 

flower

Well-Known Member
#12
Yep...all of the above. It's air inside the canister, when you first clean it,, all the air has to get out before it runs smoothly with no bubbles, if there is a leak and air gets in, bubbles result as well. I have never had the problem Bang Guy mentioned, but it makes sense. I always used a spary-bar, which restricts the output, which would explain why I never had that particular problem. I loved all of my Fluval brand filters, even the HOB...it's a good brand.
 
#13
the fix-------is to unclip the ribbed pipe on the intake hose----lowering the intake screen tube & connector all the way under the water----wrap the ribbed pipe more around. so that the connection is under water. than reclip clips-----the air gets in there at the rubber connection to the tube ---so ribbed hose 1 in under water with connection. cheers
 
Top